0 votes

I built and uploaded my game to the Google Store a few months ago using 3.2.1. Now I'm about to add IAP to this game and noticed that the previous GodotPaymentsV3 used in 3.2.1 is deprecated and GogotGooglePlayBilling is used instead, so it means I MUST upgrade to 3.2.2 in order to add IAP in the update to my game?

... and what about payments for iOS?, same situation of needing to upgrade to 3.2.2 before implementing it?

Note that I'm avoiding to update to 3.2.2 as I don't want to face unwanted "surprises" as usually happens when changing the engine version (I've seen many times that the game breaks just because of engine update).

in Engine by (16 points)

2 Answers

0 votes

Well, answering to myself (and in case anybody else is wondering the same by now): no, it's not mandatory to use 3.2.2 (or above at the moment of writing this) as my game still uses 3.2.1 (even if 3.2.3 is already stable now), and there has been no problem with Android Billing.

Also, about iOS, as it's not the same singleton, there's no problem in that platform regarding the Godot version in use (puls 3.2.1 is quite stable in that regard)

by (16 points)
0 votes

If you are doing iOS export, you need to use 3.2.3 - 3.2.2 has some issues with mono version.

by (27 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.