0 votes

I can't seem to open my characters gdscript no matter how hard I smash my mouse against my desk...
It works with other scenes just not this specific scene... idkw I'm missing:
YT video

in Projects by (54 points)

Ik this is kinda obvious but... you tried restarting godot? Or making a new script?

In the video you can see jim.gd right above jim.tscn(the scene), did you try to just double click in that jim.gd file?

I did, it doesn't show up in the editor for some reason

restarting doesn't work. It does work when I make a new script but that defeats the purpose.

if I load the script in any way (from loading it from the "Attach Node Script" to double clicking on the script in the "FileSystem" ribbon) this guy shows up:
enter image description here

when I allow it access, this process called "cfprefsd" takes over my cpu and just slows down my PC so much that I swear I saw it moved backwards in time... I had to restart my whole PC.

I had to hit cancel a few million times just to get the prompt to shut up.

Is there a check box that I misclicked from the preference settings or something?

sorry, I'm not sure the image is showing up:
https://photos.app.goo.gl/LUzwQUCd9aXhbAF2A

but why making a new script defeats the purpose? if its because you loses the code you can open the script on notepad directly from the project folder copy all the stuff inside and paste in the new script file. if even in notepad the file wont open it must be corrupted somehow.

No, I mean't it defeats the purpose of having an editor that's suppose to open it up normally. Why have a tab that's suppose to let you open a saved file if it doesn't actually do that :(...
maybe you're right. Maybe it is just a corrupted file... but I wanna know how it got borked so I could fix it so I don't have to do this for the hundredth gdscript.

ps: I can open the file with TextEditor and make a new script out of it and it totally works, the editor can see it each time I restart godot but I really want to know why it does that from time to time. Is it a glitch? is it my setting? it isn't because of the update cause I just made jim a week ago I can tell you that much at least :(

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.

Categories