+1 vote

log:
BOOT SPLASH:
BOOT SPLASH IS :
ERROR: loadsourcecode: Condition ' err ' is true. returned: err
At: modules/gdscript/gdscript.cpp:2062.
ERROR: load: Condition ' err!=OK ' is true. returned: RES()
At: modules/gdscript/gd
script.cpp:2739.
ERROR: load: Method/Function Failed, returning: RES()
At: core/io/resourceloader.cpp:218.
ERROR: start: Condition ' res.is
null() ' is true. Continuing..:
At: main/main.cpp:1330.
ERROR: setcodebuffer: Condition ' version>5 ' is true. returned: ERRINVALIDDATA
At: modules/gdscript/gdtokenizer.cpp:1061.
ERROR: operator[]: Condition ' p
index<0 || p_index>=size() ' is true. returned: aux
At: core/vector.h:128.
segmentation fault

in Engine by (427 points)

You need to post a lot more info for these kinds of bugs. What version of godot? Did you import the templates for that specific version? What OS do you use? When did it crash (on export or when opening the exported binary)? Etc.

I just tried exporting to 32 bit Linux from 64 bit Linux Mint 17.3 using the Godot 2.0.1-stable binary and everything worked fine.

i compile godot, and export the project, now the log is:

ERROR: tryopenpack: Pack created with a newer version of the engine: 2.1.0
At: core/io/fileaccesspack.cpp:173.
BOOT SPLASH:
BOOT SPLASH IS :

And i get a grey window with nothing on it...

Using linux mint 17.1 32 bits, exporting to same plataform

one minute, will gather more info

Did you also compile the export templates? Are you saying that it didn't work when you tried the version in the downloads?

first try: try with version 2.0.1 in the download site, try exporting for windows, linux, html5, 32 and 64. all fail. the first log i post was the log when executed the program in terminal, nothing appear. the game work fine in the editor.

second try: compile from source, from tutorial in the site, also export the templates: used these commands:

user@host:~/godot$ scons platform=x11 tools=no target=release bits=32
user@host:~/godot$ scons platform=x11 tools=no target=release_debug bits=32

then try export again, version 2.1.0 and the output whas the last one i posted

using linux mint 17.1 32 bits

sorry if i not giving right information, i am new to all this...

Wait, so when you downloaded 2.0.1 from the download site, did you also download the export templates and install them? When you run the engine, open any project, press Settings on the top right, click Install Export Templates, then select the file you just downloaded.

ok...working now after this. sorry for the trouble, felling really dumb right now, lol. thanks for your patience man!

haha, no problem. But I'm a little surprised that you figured out how to compile the engine before figuring out how to install the templates :P And if you do want to compile the engine and templates yourself, then you need to link them manually in the export window. The ones you just installed go into the .godot/templates folder in your HOME directory, and every time you change to a different version of Godot, you have to reinstall them.

"But I'm a little surprised that you figured out how to compile the engine before figuring out how to install the templates"

i'm asking me this right now :DD

1 Answer

0 votes
Best answer

I'll add the answer here for the sake of the Q&A.

You have to download and install the export templates before you can export anything.

When you run the engine, open any project, press Settings on the top right, click Install Export Templates, then select the Export Templates file you just downloaded.

by (846 points)
selected by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.