0 votes

Helloooo :D
I'm trying to make my own AutoTile(TileMap). I used bright colors first so I can check that it works. However when I load the colors in Godot, they're really dull. I haven't changed any settings or import options other than turning the Filter property off!

Why is this happening? Here's my screenshots:
https://imgur.com/a/1LK4i9D

Godot version 3.4.2 (stable official)
in Engine by (20 points)

I tried color-picking the color from the tileset you sent and then the tiles you placed using AutoTile. The color values are almost the exact same, barring what is essentially a one digit difference that shouldn't at all impact how it looks (meanwhile there's a bunch of other tiles on the 1st picture that have the exact same color on the 2nd)

https://imgur.com/a/Il9JmnO

I'm not saying you're wrong, though - it could be that the colors simply look dull on a gray background (which is more of a color theory question), or perhaps you used different monitors. But given what you've sent, it doesn't really look any different at all.

I think you're comparing the wrong images?

My tilemap(first image) is the bright colors, what it's supposed to look like, and then my next image in in Godot, being dull:

You can see me highlighting the difference here.
https://imgur.com/a/xYVCKVu

I'm viewing the bright colors on MS Photos(and Krita), and it's dull when imported to Godot(same monitor).

I really appreciate any help provided :)

Oh, okay. That's really weird, I'm certain I wasn't comparing the wrong images. They indeed appear more colorful on the screenshot you made, but the original images in the Imgur post don't for me, for some reason. Here, let me show you what I see:

https://imgur.com/a/eNcu2oB

Either way, no, there's nothing wrong with the import settings. However, the fact that there is somehow a clear difference between what we see is interesting. Maybe it's related to the picture itself and not Godot's import settings?

How were they drawn ? Are You sure they are not semitransparent ? Like with 0.8 alpha brush or so ? Check it in your paint program

I just saved that tileset to my desktop and apparently, the icon on the desktop for this image has the right, bright colors, but then when I view it in my image editor, the colors are dull.

There is something wrong with this file.

I really appreciate your responses. It really is confusing to me. I saved it as a PNG?

I used Krita.. works fine, "Save As", ".PNG file" etc.

Also, that's really weird that on your Imgur it shows the same dull O_o

I'm just trying to make a simple game ;-; xD

I'll add a ColorRect behind the tileset to see if it is a bit transparent :\

Please don't give up on this, one, much help is needed :P

There is definitely something wrong with the image file. I opened it in paint.net and it was grey. This is infuriating. My image was made [in krita] with different layers. Do you think flattening had anything to do with the color change?

I don't think flattening should be the culprit. Maybe there is some project settings you have for Krita that caused this. Something involving color depth, maybe, or other things. Check these out. I don't know how Krita works, however, so I don't think I'll be of much use at this point.

But you have options, you could either redraw the tileset from scratch in Krita and see if the issue persists, do the same but in a different app, or ask on Krita forums what's wrong if you still can't figure it out. The first two suggestions are probably the quickest.

I still think they have some level of transparency. Test how they look on different colors of background in Godot.

That's also possible, though when I downloaded the tileset, it didn't really seem transparent at all. I dunno.

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.