+1 vote

As the title suggests, I'm trying to make a radial textureprogress. Everything works fine, except for the progress texture, which seems to add a big pink cross to the texture. I've searched stack overflow and other sites and have seen images of the same problem, but nobody seems to address it. What is it, and how can I get rid of it?

Godot version 3.4.2
in Engine by (103 points)

If you litterally just added a texture to a TextureProgress radial and it has a pink cross while there is no pink in your original texture, then maybe it's a bug?

Otherwise there is no way to help you here without seeing your texture and setup.

1 Answer

+1 vote
Best answer

I think I realized something. You mean a pink cross in the editor? That's the editor's gizmo. That pink cross will not show up in your game.

I don't know if there is a way to turn it off. Gizmos have options in 3D but not as much in 2D. Maybe a proposal should be opened in https://github.com/godotengine/godot-proposals/issues

by (28,882 points)
selected by

Seems like you're right. It only shows up in the editor. I think they should change the gizmo in that case, since it appeared more like an error to me.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.