0 votes

Me preguntaba si en Godot 4 seguirá funcionando GLES 2.0, porque mi pc no soporta GLES 3.0 ni Vulkan

in Engine by (12 points)

1 Answer

0 votes

This is pretty old, but it's one of the only answers I could find so far.

As it seems clear that we will be moving to Vulkan on desktop and OpenGL ES 2.0 on mobile and web, further work on the current OpenGL ES 3.0 rendering backend is pointless as it will be rewritten.

[...]

For a while, we will then offer three backends to choose from: OpenGL ES 2.0, OpenGL ES 3.0, and Vulkan (the default, when ready). Once the Vulkan backend is well tested and proven to fulfill everything we need it to, the OpenGL ES 3.0 backend might be deprecated and replaced.

There's also this Reddit post. Also, here's something from Juan's Twitter.

It appears that though GLES 2.0 will be kept, it won't have as many features that Vulkan has, like 3D and it will be difficult to enable.

by (7,190 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.