0 votes

Hi! I have recently started seeing this error in debug:

Condition "!idmap.has(prid.get_data())" is true. Returned: __null

It shows once every frame after the game has run for about 1-2 mins. I have no idea what conditions are causing this but if I knew what in the hell the error meant I might start looking. Any tips appreciated.

Godot version 3.2.4
in Engine by (422 points)

Which version of 3.2.4 exactly?

Windows 64 bit. Same thing happens in 3.2.3 actually.

This actually persists in 3.3. Thing is that sometimes, without changing anything apart from switching scenes a couple of times, or turning the editor off and on, the error stops. I'm a bit dumbfounded.

1 Answer

0 votes

Are You sure You don't recognize any names of your nodes in this error ?
I am pretty sure i was getting something like this, it makes me think of shape geometry engine or astar. However it seems to indicate, that something went missing while being tested if it exists ( by get-node-or-null function)

by (2,416 points)

It looks like an error from the C++ source code

Yes it's a C++ error, nothing to do with my node names. I saw this error reported on github but the devs closed the issue without any indication of resolution...

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.