0 votes

Every time I try to reference a node in this one script I get the error

Invalid set index 'text' (on base: 'null instance') with value of type 'string'.

and the strange thing is that this has never happened before and the script has been working for almost 4 weeks now with no issues and one day I start up Godot and it just won't stop giving me that error but if I try to reference things in any other scripts it does it perfectly fine, and I have checked multiple times there is no spelling errors or any errors on my part to the best of my knowledgedge

Godot version 3.2.3
in Engine by (68 points)

well, just yesterday, I also run in to a couple of annoying "null instance", turns out the node or rather scene I was preloading got corrupted. (there was a power outage so that might be the reason)

Although It's probably not the case for you, but a bit more context, node structure or code snippet would help to diagnose the issue.

onready var animationPlayer = $AnimationPlayer
animationPlayer.play("Bounce")

this is the main thing I am having the problem with I did leave Godot open for a long period of time though I don't think that would do anything

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.