0 votes

Hello,
I setup a a scene with a viewport (containing just a label node) and a mesh plane.
The plane's material is set as billboard, and the billboard texture is taken from the viewport.

I made the material local to scene, because i need to instance the scene many times, and i need to read the content of the label text in the billboard (which is different for each scene).
For each instanced scene, the debugger shows me this error:

getnode: Node not found: Viewport
setup
localtoscene: ViewportTexture: Path to node is invalid

It looks like it is not being able to find the viewport node, except it is, as i can see the correct label text being displayed in the billboard.
I wouldnt care too much, but this thing is flooding my debugger and i cannot see any additional errors.

Any clue??

in Engine by (1,499 points)

1 Answer

0 votes

Hi. Did you resolve this? Someone somewhere said that all you need is put the viewport node above the node which will receive the texture (in the tree). Otherwise the mesh plane (in your case) will want to use the texture even before the viewport was loaded.

by (29 points)

sorry dude, this is too old, i dont even recall what project i was working on

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.