+1 vote

Hi!
When I export the project, the executable doesn't work unless it's in the project folder. Some resources don't load, even with the pck or the .zip files present, I also downloaded the templates again and from file. I'm on Windows 10 using Godot 3.2.1, but we have the same problem in other computers and Linux systems.

Here is the output:

Godot Engine v3.2.1.stable.official - https://godotengine.org
OpenGL ES 3.0 Renderer: AMD Radeon HD 6700M Series

ERROR: No loader found for resource: res://Assets/rua para blender/rua com faixada.jpg.
At: core/io/resourceloader.cpp:285
ERROR: Can't load dependency: res://Assets/rua para blender/rua com faixada.jpg.
At: core/io/resource
formatbinary.cpp:655
ERROR: Failed to load resource 'res://Assets/rua para blender/Materiais
001.material'.
At: core/io/resourceloader.cpp:208
ERROR: Failed loading resource: res://Assets/rua para blender/Materiais
001.material.
At: core/io/resourceloader.cpp:278
ERROR: poll: res://Scenes/test
posiciones.tscn:3 - Parse Error: [extresource] referenced nonexistent resource at: res://Assets/rua para blender/Materiais001.material
At: scene/resources/resourceformattext.cpp:440
ERROR: Failed to load resource 'res://Scenes/testposiciones.tscn'.
At: core/io/resource
loader.cpp:208
ERROR: Failed loading resource: res://Scenes/testposiciones.tscn.
At: core/io/resource
loader.cpp:278
ERROR: poll: res://Scenes/main.tscn:4 - Parse Error: [extresource] referenced nonexistent resource at: res://Scenes/testposiciones.tscn
At: scene/resources/resourceformattext.cpp:440
ERROR: Failed to load resource 'res://Scenes/main.tscn'.
At: core/io/resourceloader.cpp:208
ERROR: Failed loading resource: res://Scenes/main.tscn.
At: core/io/resource
loader.cpp:278
ERROR: Failed loading scene: res://Scenes/main.tscn
At: main/main.cpp:1864
WARNING: cleanup: ObjectDB Instances still exist!
At: core/object.cpp:2071
ERROR: clear: Resources Still in use at Exit!
At: core/resource.cpp:476

It really looks like something I'm missing.
Thanks!

asked Apr 9 in Projects by cool_bean_stuff (13 points)

Hello, am facing the same issue, did you find a solution to this ?

1 Answer

0 votes

Use user:// instead of res://. res refers to the project folder, that's why it won't work elsewhere.

answered Apr 9 by Magso (2,713 points)

I do have res instead of user in every script, but the problem still happens.

What settings do you have in Export > Resources tab?

I have export every project resource, and the rest is empty.
I've also tried with compiled and with text script, still no good.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.