+3 votes

Hi,

I configured Godot as described here: http://docs.godotengine.org/en/latest/tutorials/asset_pipeline/exporting_for_android.html

I can run the godot-demo games without any problem on my Sony Xperia Z5, but if I export a project of mine it just flashes or shows a black screen. How can I debug that?

I'm pretty much using the latest master.

in Engine by (307 points)

Did you compile the Android export templates too?

I'm using the templates for 2.1-beta.

I checked "Deploy with Remote Debug" and now I get some output:
https://imgur.com/NZrctgo

2 Answers

0 votes

Did you set a main scene?

by (88 points)

Of course. I tried different ones, but it's either flashing or just black.
I don't even get any debug output of prints from the _init() or _ready().

0 votes

I have the same problems., and have resolved it.

May be you need to compile the editor, and export android with it.

https://godotengine.org/qa/7172/godot-logo-blinks-continuously-dosent-loads-android-phone

by (86 points)
edited by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.