0 votes

For those who may have this trouble, I found that it was the f.lux app running in the background. Thanks to Calinou for a link to some responses that ended up containing my problem.

After asking on the forum with no response, I thought I'd ask here.

I have a small scene with default settings containing one staticbody2d for the ground and a rigidbody2d for the player sprite. I created a script to move the player, but it janks every couple seconds while moving left or right. It doesn't move smoothly whatsoever. I can't figure out why.

I run Godot on an i7 laptop with 12GB ram and an Nvidia GPU. What would cause the sprite to stutter for a split second then be fine, then jank again. Any ideas? Here's a link to the file if anyone wants to see where I screwed up if at all, but I'm thinking it's my machine that's causing it.

If it runs without a stutter every couple seconds for someone else, then it has to be something wrong with my laptop. Thanks for looking.

https://drive.google.com/file/d/0BxVOSlaJfQK5Y0o0d0lmR1FqcFk/view?usp=sharing

in Engine by (19 points)
edited by

You may be a victim of this bug.

It was the f.lux app running in the background. Thanks for the link.. it was farther down on the page where someone said something about that app, and I turned it off and it worked. Thanks again.

It's better if you post your edit as an answer and select it. Much better than the "[solved]" approach. The way it is the question will still shows as unanswered.

Done, thanks!

1 Answer

0 votes
Best answer

For those who may have this trouble, I found that it was the f.lux app running in the background. Thanks to Calinou for a link to some responses that ended up containing my problem.

by (19 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.