0 votes

When I export my project, it stops at about 33% of my total project, and about 84% of the assets, but doesn't show an error. The exported project opens to the main menu without problems, and I can navigate to certain scenes from the main menu. But the actual game scene itself is not opening. The output log is not helpful at all, but if I can get a more detailed report of the export logs, I'll know where to start looking for possible problems.

This is the current output:

ADDING: Contents/Resources/icon.icns size: 91969
ADDING: Contents/Info.plist size: 1095
ADDING: Contents/PkgInfo size: 9
ADDING: Contents/MacOS/My Game size: 40666104

I am exporting on a mac, however, this is happening regardless the type of export I am doing (mac, windows).

Also, I did an export much earlier in development to get templates working/see how it looks, with no problems.

asked Aug 14 in Engine by cmdrsteel (19 points)

Maybe you should try a reinstall?

the actual game scene itself is not opening

How do you know the export actually doesn't include some scenes? It could be a lot of different errors instead. The game closes? Freezes? Nothing happens?

I click on it and nothing happens. I agree that it could be other things, such as something in the scene causing it to not load. Here is the game code that is being used that doesn't open.

func onNewGamepressed():
gettree().changescene("res://main.tscn")

I can still click on options before and after clicking new game without problems.

func onOptionspressed():
get
tree().change_scene("res://options.tscn")

Does this happen in a test project? Otherwise are you able to provide your project (or a reduced version of it) to see if I can reproduce it?

Cutting the project down help me find the problem

1 Answer

0 votes
Best answer

I discovered the problem. I had a WIP graphic for a sprite called "Skull.png". I then removed the file from the folder outside of the Godot editor and added the file "skull.png" (notice the lowercase 's'). However, there was no problem within the Godot editor, so I didn't notice.

I tested this with a new project. I added a sprite using a small png called "bug.png". I was able to run it in the editor, and after exporting it, it ran just fine. Outside of the editor, I removed "bug.png" and added a new png to the folder labeled "Bug.png". Inside Godot, I was able to run the editor and play the scene just fine with the new sprite. However, the export closes immediately on launch (only one scene, so it doesn't work). In addition, I tried it again with a much larger png called "BUG.png" with the same results.

answered Aug 15 by cmdrsteel (19 points)
selected 6 days ago by cmdrsteel
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.