0 votes

Recently, I created a New_Project in Godot 3.1. After customizing my level and organizing the assets, I decided to add some color to a few assets.

I created a New_Gradient image for my mesh.
I did this for Surface 1 & 2.

I then saved both gradients and placed them into a corresponding folder.

Upon re-loading of my scene at a later time, everything except the gradients I had applied were gone and when I went into the folder to re-load them, Godot told me they could not locate the resource for the file.

Essentially, it was an easy Gradient so I just re-made the Gradient. This leads to my questions.

1) Did I do something wrong?
2) Does a Gradient require a shader?
3) How do I correctly save and re-load my Gradients?

thank you,

zee

asked Jun 30, 2019 in Engine by omzee (12 points)

1) I'm not sure, there might be a scenario in which that thing can happen (if your mesh is from an imported file and it got re-imported over for example), but you need to provide more information about which steps you exactly did. What you described was too vague.

2) Not really. A Gradient resource is just a gradient. To be usable by the graphics engine, you need to create a GradientTexture which contains or reference the Gradient (maybe that's what you did but I can't tell). Then, you can assign the GradientTexture on any "texture" property, which may not necessarily be a shader material.

3) Any resource from the inspector can be saved as a file by using the floppy icon on top of it, then "save as". Or, right-click on the property that contains the resource, and "save".

Hello, thanks for the reply Zylann.

1) Yes, I exported the file as an (.obj) file from Blender. I did not attach any meshes inside of the Blender application. These 3D models will not allow me to "save" any colors to them inside of the Godot Engine. Only on my 3D models that I exported from Blender are having this issue.

I am able to apply color inside of the Godot Engine to my 3D models, but once I save and re-open the Project. The colors are gone, but the models are still intact.

regards,

zee

It would seem you are editing the imported mesh directly, for which "changes may be lost" as often indicated on them. Did you try assigning materials from a new MeshInstance using that mesh, rather than the mesh itself?

Sorry for late reply I could not remember password.

Thank you, I was saving my gradients to the wrong portion of my scene that I imported.

I instead created a "New Inherited" scene also I could change the imported model and now everything is working just fine!

It wasn't anything with Godot, I was not correctly loading my imported scenes.
Everything is working fine now!

Thank you for the reply Zylann!

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.