0 votes

Hello,

I am getting the following compilation error when trying to compile the latest stable version of the engine (3.1) on Linux Mint 19 (platform=x11):

[Initial build] Linking Static Library ==> core/libcore.x11.tools.64.a
Ranlib Library ==> core/libcore.x11.tools.64.a
[Initial build] Linking Program ==> bin/godot.x11.tools.64
/usr/bin/ld: cannot find -lGL
collect2: error: ld returned 1 exit status
scons: *** [bin/godot.x11.tools.64] Error 1
scons: building terminated because of errors.

All prerequisites appear to be correctly installed. Can somebody help me out please? I would like to compile the engine as I am adding an external C++ module.

Screenshot #1: Compilation error
Screenshot #2: Prerequisites

Thank you,
David!

asked Mar 29 in Engine by ant1fact (16 points)

1 Answer

0 votes

After a few hours of trial and error I think I have found the solution. I had to set up the a link to the correct version of libGL, in my case 1.7.0

$ sudo ln -s /usr/lib/x86_64-linux-gnu/libGL.so.1.7.0 /usr/lib/libGL.so
$ sudo ldconfig

answered Mar 29 by ant1fact (16 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.