0 votes

I'm currently on Ubuntu 18.10. I have followed all the instructions here and at https://godotengine.org/qa/28667/godot-mono-c%23-in-ubuntu-bionic?show=28667#q28667 , and am unable to install mono 5.12.0 on my machine.

/etc/apt/sources.list.d/mono-official-stable.list says:

deb https://download.mono-project.com/repo/ubuntu bionic/snapshots/5.12.0 main

When I attempt to install mono-devel, I get:

sudo apt install mono-devel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-devel : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
              Depends: libc6 (>= 2.27) but 2.26-0ubuntu2.1 is to be installed or
                       libc6.1 (>= 2.27) but it is not installable or
                       libc0.1 (>= 2.27) but it is not installable
              Depends: libglib2.0-0 (>= 2.56.1) but 2.54.1-1ubuntu1 is to be installed
              Depends: libmono-cecil-private-cil (>= 5.12.0.301) but it is not going to be installed
              Depends: libmono-cecil-private-cil (< 5.12.0.302) but it is not going to be installed

followed by a whole lot more equivalent stuff. I have tried turning off my other repositories, and still get the same result.

It looks like the problem is that everything mono is trying to do is depending on libc6 >= 2.27, and ubuntu has libc6 2.26, but I'm not sure if that's the root of the problem or not. I tried setting it to point at the older version of 5.12.0 (5.12.0.226), and had the same problem.

asked Mar 12, 2019 in Engine by maquis (19 points)

1 Answer

0 votes
Best answer

Okay, I think I found the problem. Looks like while my computer claimed it was on 18.10, the apt sources list was incorrectly set up for an older version of Ubuntu. So, I am fixing that, and upgrading the packages on the system, and hopefully that will fix the issue.

answered Mar 12, 2019 by maquis (19 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.