0 votes

I'm trying to get a Sprite with a normal map to work with a Light2D node. I have recreated a minimal project with just the Sprite with the normal map and basic movement, and the Light2D node. It works fine in the stripped down project. However in my main project, it is acting weird, and is not working as I would expect.

Video demonstration - main/original project - not working

Video demonstration - minimal project - working correctly

The only difference that I can think of between the two projects is that in the main project I am using an AnimationPlayer to animate the thrusters, which just switches out the whole sprite for each frame. However, I have tried adding a second track to all my animations that includes the normal map propery, and that doesn't improve anything.

Any ideas what would be causing it to look the way that it does?

in Engine by (1,605 points)

1 Answer

–1 vote
Best answer

I figured out the issue. In my main project I am using a spritesheet with the AnimationPlayer to handle my animations. However, I was still only using a single normal map image (one frame's worth). I only need the one normal map, which is the same for every frame of the animation, however I needed to create an additional spritesheet that mirrored the main spritesheet, where each frame is the one normal map.

by (1,605 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.