0 votes

So I'm not sure if I'm using the TextureButtons correctly, but the way I have them set up is I assigned a png to the Normal, Pressed, and Hover textures but no matter what I do the image in my scene isn't changing. The node structure is as follows:

-Node
--Texture Button

Additionally, the pressed() signal is only sending when I use my touchscreen to tap on the button and the texture still doesn't change. Everything else aside from the 3 textures I listed above I left untouched.

Thanks again!

in Engine by (58 points)

Maybe the TextureButtons need to be children of a parent Control node? I'm not sure.

I'm currently using TextureButton and I have not such problem.
When you say touchscreen, what kind of device and OS are you on?

Didn't work :(

I'm using a Windows laptop with a touchscreen.
Edit: Okay wait, it's working in a completely new project, but not the one I'm working in for some reason :thinking:

Go through your project settings and check, also check the mouse filter for your button.

Enabled focus is set to All, and I'm not sure what setting I'm looking for in Project Settings.
Edit: Oh I'm dumb (see answer) ty for the help though I eventually found the problem

1 Answer

+2 votes
Best answer

I'm dumb, please disregard. I had a singleton that was resetting the scene because my test scene didn't have a specific object lol

by (58 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.