0 votes

I'm experiencing bugs with the engine, I can't close the engine with the X button, the only working way is to kill the process. I've the same trouble when I preview my project, get_tree (). quit () has no effect too.

Another thing, in the project setting window, clicking on tabs like "run" show nothing in the panel.

I've disabled all extensions that can alter the engine behaviour.
All other projects work perfectly, it's definitely related to my project, I can send it in MP.
Windows 10 64 bits

Someone had experienced same bugs?

in Engine by (12 points)

Don't know if I can assist you, but... have you tried pressing F8 when previewing the game? That may stop it from running.

If it's not exiting that means your project is broken somehow. Did you check the debugger when running?

There is nothing in the debugger, no error. Maybe there is a log file?

Sounds like an infinite loop somewhere. I'd try adding breakpoints at various spots and tracing through the code.

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.