0 votes

I'm having a little problem with my collisions and I have no idea why.

Basically, even if I remove my collision for my block tilemap. My character still collides with it, and I don't know why. I checked the tilemap but there is no collisions turned on in there.

I made a video so you can see for yourselves. First, I moved the collision upwards, you can see that when this happens the player can jump pasts the red blocks... okay, that's fine. But when I delete the collision for that part, the player collides with the red blocks now.

Any ideas as to what is happening? Apologies in advance for the bad quality, the website I used must have used some weird compression, it didn't look that bad when I recorded it.

Here is the video: Video Link Here

in Engine by (88 points)

enable "Visible Collision Shapes" so you can see what's there at runtime

Unfortunately, that didn't show much.
Link here

Weird... did you try changing the layer/mask or deleting the collision, then save and restarting the editor? Maybe it's a bug...

I have, I'm not really sure what is going on. Oh well, I can work around it luckily.

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.