0 votes

I can't believe that you have to make your game install only on 4.0.1+ android version. I would like to make it 2.3+ . Can someone help me understand how to do it? Thanks guys

in Engine by (49 points)

3 Answers

+1 vote

Dont believe you can, godot needs 4.0

Could be wrong, not totally sure

by (483 points)
+3 votes

I believe the support for android versions below 4.0 has been dropped in 2.0. It has already been discussed in https://github.com/godotengine/godot/issues/3784.

by (25 points)
+1 vote

if you really really want to make an android template supports 2.3,
you can try to make your own android template.

  1. get source code at github ( https://github.com/godotengine/godot )
  2. change minSdkVersion 14 to 10 in platform/android/build.gradle.template
  3. here is guide for making android template.
    http://docs.godotengine.org/en/latest/reference/compiling_for_android.html

I'm not sure this works fine because I didn't try with sdk version 10.

by (9,752 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.