+1 vote

When I open up Godot, it seems to mostly work normally, except it keeps a second window open the whole time, containing an error message. If I shut this window the main Godot window also shuts.

I've been doing some tutorials on Godot, and it's seemed to work normally, until now. For my project one of nodes isn't detecting a 'signal' sent by the other node. I'm positive I haven't made an error, the only thing I can think of is this. I fear the only solution may be to get new hardware, since I'm working on my laptop which is fairly old and low-powered, and after doing some Googling it seems my laptop's processor might just not be able to run all of Godot properly.

Here is the error message:
Godot error message

My computer's processor is a Pentium(R) Dual-Core CPU T4500. It is a Dell laptop that runs 64 bit windows.

Is there any solution (such as using a different version of Godot)? Or is the only solution newer hardware?

in Engine by (13 points)
retagged by

1 Answer

0 votes

You might want to try to update you graphics card drivers.

by (334 points)

I don't think this will solve it, OP seems to have a very old graphics card (probably Intel integrated graphics, in fact). Those might be able to run Godot on Linux (and I'm not sure support has been kept for them in recent distributions), but not on Windows.

So, I don't think it's possible for them to run Godot on that laptop. Getting a new computer is the only solution, and this will be especially true with Godot 3.0, which will require OpenGL 3.3 on desktop/laptop platforms for the new renderer.

I have read some people having similar issue have just solved it by updating old drivers.
Now, I am not guaranteeing the result.

But this could be a quick checkpoint before deciding changing card, imho.

But I can't see a connection to the OP's initial problem, the node not detecting a signal.
Maybe, @godotnoob, you want to post the code you are using for that?

That didn't work, my Intel Graphics card was updated. I'm with the same problem, but some months ago it worked well! Its the same Godot executable, the same system, everything is the same and I don't know why it worked before or why now it is not working anymore. My system runs under a i5 core.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.