0 votes

I'm testing multiplayer and during the test I noticed that one client can connect, and subsequent players receive the error "No network peer is assigned. Unable to get unique network ID." Exactly the same code, on a clean project does not cause such problems - I can not understand what this could be connected with

in Engine by (71 points)

I've been trying to write up some questions to understand your problem better, but I can't think of what could be the issue.

It seems like some project setting would be the only difference between your project and a clean project... not sure how you would compare, but do you remember changing any project setting in the project that isn't working?

One thing that has helped me with an unrelated issue is clearing the project cache... on windows it's in %appdata%/roaming/godot/projects/yourProjectName... or something like that... and in your actual project folder, deleting the .import folder and all the .import files... I can't imagine what could this could change for you, but as a last resort

Show us some code

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.