0 votes

Hi...,

I want that the z-axis of my PathFollow aligns always to the Path in Godot 3.3.2.stable.

A) Rotation Mode "Y": The rotation first works, but for the second time, when I set the PathFollow back to unit_offset = 0, the current y rotation is not set back, and just added. Not nice.

So I tried

B) Rotation Mode "Oriented": This seams to work, from unit_offset 0.0 to 0.999, the z-axis of the PathFollow is aligned to the Path correctly. But at unit_offset 1.0 suddenly the x-axis is aligned to the path. This seams like a bug.

Please can a developer take a look.

What to do?

Thanks

Mike

in Engine by (99 points)
edited by

I've found bug reports about this:

https://github.com/godotengine/godot/issues/3713

https://github.com/godotengine/godot/issues/27137

https://github.com/godotengine/godot/issues/36258

Seams PathFollow is not usable at this stage. Or have I missed something?

1 Answer

0 votes

Hi...,

OK, I have written a bug report:
https://github.com/godotengine/godot/issues/50973

I hope someone will fix this.

Thanks

Mike

by (99 points)
edited by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to webmaster@godotengine.org with your username.