02
Jan 2017


Juan Linietsky

WARNING: HEAD is going unstable!

We know Godot has been known for many years to have a relatively stable master/HEAD at Github, so users can try the new features in their projects with very little risk of breaking them.

Starting now, and only for the upcoming 3.0 release, HEAD will break compatibility completely. Projects from Godot 1.x and 2.x will not work and this is expected.

Godot 3.0 is expected to be a compatibility breaking release. We will take the chance to do deep changes in Godot internals, which (while for the better) will render it incompatible with previous versions.

Moreover, starting new projects in the HEAD branch, using the new features and expecting them to work with the upcoming 3.0 release is discouraged - unless you want to help find and fix bugs in the development code of course.

Please wait at least until we can release an Alpha!

Some time before the 3.0 release, we will create a tool for project migration, which should make it easy to move to Godot 3.0 with as little work as possible. In the meantime, keep using Godot 2.1.x :)

Thanks for your patience and understanding!